TIM - Fehlersuche und -behebung (EN-US)
Table of contents
Libraries and directories for TIM
- TMSTIM
- TMSTIMDTA
Troubleshooting on IBM i
Determine version
IBM i version
GO LICPGM
, selection 10, key F11
TIM version
GO TIM
Selection 1 - The version number is displayed at the bottom left of the screen
Start/Stop commands
GO TIM
- Selection 26. start subsystem TIM
- Selection 27. stop subsystem TIM
Subsystem and jobs
SBS-TMSTIM
Jobs
- TIMEXCORD - only available if an order is actively executed
- TIMCTL
- TIMMONIFS
- TIMTRCIFS
Logs/Protocols/Dumps
Log files
GO TIM
- Selection 10. show FTP transfer log file
- Selection 11. log file install. messages anz.
Hotline cases
"Manual" download of files brings "hieroglyphics".
Summary:
TIM has no FTP access and creates the README download file.
You open it, but clicking on one of the links brings only a browser page with hieroglyphics.
Solution:
Right click on the link and
- Save target as... (Firefox, IE)
- Save link as .. (Chrome)
Installation of a product via TIM does not proceed
2019-12-06
Problem
The status does not change status for a long time, it remains "Downloding".
The files INST_DIRMAIL_055000.SAV and INST_WOPIXX_023400.SAV are already in the install directory(the file names are only examples!)
Notes F10: Other products, components or versions are required
Status: WOPIXX 01 RUN... and DIRMAIL 01 RUN...
Cause
Probably unstable line
Solution
Clean up and get the downloads via PC
- Shut down TIM subsystem (Aw. 27)
- CHANGE_ORDER - set order status to Hld
- REMOVE_ORDER - delete all orders
- get the SAVFs manually via Windows download → IFS /TMSTIM/input set
- Start TIM subsystem (Aw. 26)