Toolmaker Produkt-Dokumentation
directfax Fehlersuche und -behebung
Inhaltsübersicht
Lizenz prüfen prüfen
Bis Version 5.92: Softkey
Ab Version 6: Lizenzdatei
Bibliotheken und Verzeichnisse für directfax
Fehlersuche und -behebung auf IBM i
Version feststellen
IBM i-Version
GO LICPGM
, Auswahl 10, Taste F11
directfax Version
DSPDIRFAXV
WOPiXX
DSPDTAARA DIRWEB/PRDREL
Befehle zur Konfiguration
Start/Stop -Befehle
STRDIRFAX / ENDDIRFAX (F4)
- Startet / beendet das Subsystem DIRECTFAX
ADDLIBLE DIRECTFAXF
- Startet den Job TCPSERVER für die Kommunikation mit den directfax/PC - clientsSTRSRV
Subsystem und Jobs
Subsystem: DIRECTFAX
Mit Jobs:
FAXCTL DIRECTFAX STAPEL AKTIV CMD-DIRECTSRV
FAXMAIL DIRECTFAX STAPEL AKTIV CMD-FAXMAIL
FAXMIX DIRECTFAX STAPEL AKTIV CMD-MIXFAX
FAXPC DIRECTFAX STAPEL AKTIV CMD-PCFAX
FAXSPL DIRECTFAX STAPEL AKTIV CMD-SPLFAX
(RETARUS DIRECTFAX STAPEL AKTIV PGM-DIRFAXCTLR)
Job TCPSERVER in Subsystem QINTER
Das ist der Serverjob für die Kommunikation mit den directfax/PC-Clients
Logs/Protokolle/Dumps
Protokollierung: Modemtrace
Der Modemtrace protokolliert den Datenverkehr zwischen dem System und dem angeschlossenen Modem oder TCU.
Die Modemtrace-Dateien sind gespeichert im IFS der IBM i im Verzeichnis /toolmaker/DirectFax400/debug
ENDDIRFAX
WRKFAXLIN
, Auswahl 2, 1x Vorwärts blättern- Anzahl Tage Modemtrace einstellen:
(Funtionstrace nur auf Anforderung der Hotline ändern)
- Anzahl Tage Modemtrace einstellen:
In den Tracedateien findet man 4-stellige CAPI-Fehlercodes (wie z.B. "3312" oder "3490", etc.). Diese werden auf vielen Seiten im Internet beschrieben. Z.B. hier: https://support.c4b.de/hc/de/articles/10135088582044-Was-bedeuten-die-XCAPI-Fehlercodes-
SMTP-Tracing: den SMTP-Datenverkehr mit dem Mailserver protokollieren
STRDIRFAX
CHGDTAARA DTAARA(DIRECTFAXF/FAXDTAARA (222 1)) VALUE('M')
- Beim nächsten Sendevorgang einer Email wird dann ein Trace des AS400-Email-Dialogs als SPLF erstellt, siehe unter
WRKJOB FAXMAIL, Auswahl 4
- Wenn man genug gesehen hat, directfax wieder neu starten, damit das loging beendet wird:
ENDDIRFAX WAIT(60) RESTART(*YES)
Wichtig: man muss den Datenbereich FAXDTAARA in diesem Fall "laufenden Betrieb" ändern, weil das "M" bei jedem STRDIRFAX automatisch entfernt wird.
Protokoll-Dateien und Nachrichtenwarteschlangen
1. DSPMSG QSYSOPR
2. OUTQ DIRFAXPRT
3. PF-DIRECTFAXF/DFFAXLOG
4. Im IFS-Verzeichnis /toolmaker/directfax400/debug (enthält die Modemtraces, wenn das Modem-Tracing angeschaltet ist)
5. WRKSPLF DIRECTFAX
(enthält die SMTP-Traces, wenn das SMTP-Tracing angeschaltet ist)
Jobprotokolle der Fax-Jobs (CHGFAXVAL JOBLOG(..) )
Der Parameter JOBLOG des Befehls CHGFAXVAL steuert, ob die Fax-Jobs Joblogs schreiben, oder nicht.
Autofax-Tracing
Mit Befehlen
CHGDTAARA DTAARA(DIRECTFAXF/FAXDTAARA (143 1)) VALUE(R)
ENDDIRFAX WAIT(60) RESTART(*YES)
Kann man das Autofax-Tracing einschalten. Dabei erstellt Autofax für jede Spooldatei, die es verarbeitet eine Ausgabedatei mit einer Kopie seiner Arbeitsdatei.
Diese wird mit dem Befehl RUNQRY erstellt. Man findet sie also mit dem Befehl WRKSPLF DIRECTFAX. Die Ausgabedatei heisst QPQUPRFIL.
Diese Funktion ist hilfreich, wenn die zu verarbeitende SPLF vom Typ *USRASCII ist. Dann kann sie selbst nämlich nicht mit Auswahl 5 angezeigt werden.
Prüfschritte
Basisprüfung
- korrekte Installation der directfax Hard- und Software
- richtige Konfiguration der Leitung - insbesondere: richtiger Ressourcenname (CMNxx - Analyse mit
GO HARDWARE
) - Stromversorgung des Faxmodems ist gewährleistet
- die Kabelstecker sitzen korrekt
QSYSOPR-Nachrichtenwarteschlange
Bei Funktionsstörungen sollte in jedem Fall zuerst mit DSPMSG QSYSOPR
die Operator-Nachrichtenwarteschlange nach Fehlernachrichten von einem directfax-Programm durchsucht werden.
Subsystem DIRECTFAX
Mit der OS/400-Anzeige WRKACTJOB
kann der Status der Fax-Sendeprogramme im Subsystem DIRECTFAX beobachtet werden. Steht dort als Status ICFW (ICF WAIT), so wartet das Programm auf eine Antwort vom Modem. Sollte dieser Status längere Zeit unverändert bestehen bleiben und wird parallel dazu festgestellt, dass anstehende Faxe nicht mehr versandt werden, so liegt der Verdacht auf eine Fehlfunktion nahe. Mit dem Befehl ENDDIRFAX sollte dann zunächst versucht werden, das Hintergrundprogramm zu beenden.
Zustand der directfax-Kommunikationsleitung
Für die weitere Fehlersuche steht der Befehl WRKCFGSTS *LIN
zur Verfügung. Die Anzeige muss 3 Einträge mit Namen DIRECTFAX (LIND, CTLD, DEVD) enthalten, die im aktiven Zustand alle 3 auf AKTIV stehen müssen. Sind sie im Status abgehängt, in der ersten Zeile Option 1 eingeben und mit F5 das Anhängen verfolgen. Kommen Leitung, Controller und Device nicht auf AKTIV, kann die Ursache bei einer anderen DFÜ-Leitung liegen, welche die directfax-Schnittstelle (Ressource LINxxx) belegt.
Ausgabewarteschlange DIRFAXPRT
Mit dem Befehl WRKOUTQ DIRFAXPRT
kann geprüft werden, ob in der Ausgabewarteschlange DIRFAXPRT Faxe zum Versand anstehen. Diese werden nur verschickt, wenn sie im Status RLS (freigegeben) sind und in der Anzeigenspalte "Ben.-Daten" keinen Fehlerhinweis enthalten.
Das Subsystem DIRECTFAX neu starten
Mit dem Befehl ENDDIRFAX
wird das Hintergrundprogramm beendet. Falls das nach der entsprechender Wartezeit nichts bringt, directfax mit ENDSBS DIRECTFAX *IMMED
abnormal beenden und nach Beseitigung evtl. Hardwarestörungen mit STRDIRFAX
neu starten.
Probleme mit Fax-Mails (als E-Mail zu sendende Faxe)
DSPMSG QSYSOPR
- gibt es Nachrichten dazu?- das SMTP-Tracing anschalten, ein Faxmail senden und mit WRKSPLF DIRECTFAX prüfen, ob es eine SPLF QSYSPRT mit weiteren Hinweisen gibt
WRKJOB FAXMAIL
- gibt es im Joblog Nachrichten dazu?
Fehlersuche und -behebung auf dem Windows Client
Version feststellen
Windows
Office
directfax-Version
Start → Programme → directfax→ directfax Administrator, Registerkarte "Info"
IBM i ClientAccess bzw. Access Manager
Befehle zur Konfiguration
Logs/Protokolle/Dumps
Fehlermeldungen an den Eigner des Faxes
In einigen Fällen (z.B. bei "MIX-Warnung") schickt directfax Nachrichten an das Benutzerprofil das Eigner des Faxes ist.
Mit DSPMSG <benutzerprofil>
suchen.
Protokoll für die Kommunikation mit den PC-Clients
PC-Protokollierung einschalten
1. CLRPFM DIRECTFAX/RPRT
2. CHGDTAARA DTAARA(DIRECTFAXF/FAXDTAARA (222 2)) VALUE('LL')
Damit werden Informationen zur Kommunikation zwischen der IBMi und den PC-Clients in die Datei DIRECTFAXF/RPRT geschrieben.
PC-Protokollierung abschalten
Die Protokollierung ist sehr umfangreich. Deshalb sollte sie nach erfolgter Analyse wieder abgeschaltet werden:
3. CHGDTAARA DTAARA(DIRECTFAXF/FAXDTAARA (222 2)) VALUE(' ')
Protokoll für Retarus-Faxe
Das Joblog der Retarus-Jobs im Subsystem DIRECTFAX zeigt die Kommunikation mit dem SMTP-Server.
Beispiel:
Fehlersuche und -behebung für die Toolmaker Communication Unit (TCU)
Informationen zur Konfiguration der aktuellen TCUB4
Für die älteren TUCX - Geräte: Fehlersuche und -behebung TCUx
Fehlersuche und -behebung für die Kommunikation mit Retarus
Support-Fälle
Nach Umstieg auf eine FritzBox (hier: 7590) kann die TCUB4 keine Faxe mehr versenden (2861)
2024-01-16
Die FritzBox 7590 stellt eine S0-Schnittstelle zur Verfügung über die die TCUB4 die Faxe versenden und empfangen soll.
Problem
In den Tracedateien (im IFS der IBMi im Verzeichnis /Toolmaker/DirectFax400/debug) traten mehrere CAPI-Fehlermeldungen auf
- 34C1 - Bearer capability not implemented
- 3312 - Connecting not successful (training error)
- 3314 - Disconnected during transfer (remote abort)
- 34D8 - Incompatible destination
Lösung
Die folgenden Massnahmen ermöglichten den Faxversand:
WRKFAXLIN
, Aw. 19, An Stelle 5 den Wert "04" eintragen- Auf der Fritzbox die Auswahl "Faxübertragung auch mit T.38" deaktivieren
Produkt – Version auf IBMi | 6.06 |
directspool (Autofax) - Definition bearbeiten bricht ab mit MSG CPF4169 - Einheitendatei enhält keinen Eintrag für Bildschirmgrösse
2021-09-22
Das liegt an der Konfiguration der 5250-Sitzung.
Die kann man mit 24x80 (gaaaanz altes Terminal) und 27x132 (modernes Terminal) definieren.
Leider ist 24x80 oft der Standard und man muss das umkonfigurieren.
Bitte melden Sie sich zuerst in der 5250-Sitzung ab (SIGNOFF), so dass Sie den IBM i – Anmeldebildschirm sehen.
Wie des dann weitergeht, hängt von der Emulations-Software ab. Bei der IBM-Software (Client Access, iAccess, ACS) gibt es in der Menüleiste den Eintrag „Kommunikation“ darunter „Konfigurieren“:
In dem Fenster gibt es dann die Auswahl der „Anzeigegrösse“. Wählen Sie 27x132:
Klicken Sie dann auf OK. Damit wird die Verbindung kurz unterbrochen und die Sitzung neu mit den neuen Parametern gestartet.
Wenn Sie ein anderes Produkt für die 5250-Emulation verwenden (z.B. Mochasoft oder Vista), dann melden Sie sich bitte bei der Hotline.
Autor: RSC
Produkt – Version auf IBMi | alle |
Faxversand über Retarus: nach Umstellung auf den Server fax4ba.de2.retarus.com gehen keine Faxe mehr 'raus
Stand: 2021-05-28
Der neue Server von Retarus fax4ba.de2.retarus.com (mit der IP-Adresse 94.199.88.203) erfordert passives FTP. Dies muss über WRKFAXLIN, Aw 19 eingestellt werden.
Details siehe: FTP umschalten auf Passivmodus.
(Beim alten Server fax4ba.retarus.com (94.199.90.40) war das noch nicht erforderlich.)
"MIX-Warnung" in WRKFAXSTS
Analyse:
- mit DSPMSG für den Eigner des Faxes nach Faxmeldungen suchen, Beispiele:
Nachricht . . . : Autom. Zeilenumbruch! Fax-Nr.: 5884 Seite: 1 Ruf:
040357090106 Fax angehalten!
Formular nicht berechtigt/vorhanden! Fax-Nr.: 5885 Obj.: ^AKEYA
Von . . . . : DIRECTFAX 27.05.20 10:16:47
- Fax an sich selbst schicken oder mit directfax/PC-Client ansehen
Die Fehlerbehebung richtet sich nach dem gefundenen Fehler.
Faxmail: Verschiebung in PDF-Anhängen bei Fettdruck (19000223)
Wenn in einer Zeile Fettdruck verwendet wird, dann verschieben sich die Zeichen nach rechts. Je weiter rechts, desto mehr:
Lösung:
CHGDTAARA DTAARA(DIRMAIL/DMDTAARA (765 3)) VALUE('0.0')
Fehler: Fax-Mails gehen nicht raus, DSPMSG QSYSOPR zeigt Nachricht FAX0060 - "Fehler beim Verbindungsaufbau zum Server"
Mögliche Fehler und Abhilfe
- Falscher SMTP-Server angegeben → Den Parameter SMTPSRV im Befehl CFGFAXMAIL korrigieren (CFGFAXMAIL, F4, F9, 1x vorwärtsblättern)
Fehler: alle Faxe gehen in den Status "Kein Wählton bzw. Keine Verbindung"
Es liegt ein Problem mit der Telefonleitung vor. Prüfen Sie zunächst Ihre Telefonanlage und die Nebenstelle, an der das Faxmodem angeschlossen ist. Prüfen Sie, ob der TAE6-Stecker in der richtigen Telefondose steckt. Schließen Sie an der TAE6-Dose ein Telefon an und achten Sie beim Abheben des Hörers und bei der Amtsholung auf die Geräusche. Sprechen Sie ggf. mit dem zuständigen Telefontechniker.
Fehler: alle Faxe gehen in den Status "besetzt"
Es liegt ein Problem mit der Amtsholung vor. Prüfen Sie zunächst Ihre Telefonanlage und die Nebenstelle, an der das Faxmodem angeschlossen ist. Möglicherweise ist die Nebenstelle nicht „amtsberechtigt". Tritt dieses Problem nach Installation einer neuen Software-Version von directfaxund Verwendung einer alten DCE Faxbox auf, bitte folgende Bedingungen prüfen:
Normalerweise ist die Amtsholung bei einer Nebenstellenanlage im Befehl CFGDIRFAX + F4
(oder GO FAXCNFG, Punkt 1) im Parameter Amtsleitungsvorwahl mit 0 oder I0 (interne Wahl möglich) angegeben.
Ist hier allerdings *NONE angegeben, geht directfax davon aus, dass die Box an einer Hauptleitung angeschlossen ist und keine Amtsholung benötigt. Ist die Box aber doch an einer Nebenstelle angeschlossen und wird die Amtsholung zusammen mit der Faxanwahlnummer angegeben (z.B. 00405591908), tritt bei neueren Boxen der negative Effekt ein, dass alle Faxe auf den Fehler "besetzt" laufen.
Abhilfe
Folgenden Befehl eingeben:
CHGDTAARA DTAARA(DIRECTFAXF/FAXCSI (135 2)) VALUE('A.')
Es ist darauf zu achten, dass nicht nur das 'A' sondern auch der Punkt dahinter mit eingegeben wird, da dieser die Automatik blockiert.
Falls mit mehr als einer Faxbox gearbeitet wird (Mehrleitungsversion) muss dieser Befehl für jede konfigurierte Leitung (2-8) eingegeben werden. Dabei ist der Datenbereichsname FAXCSI für die 2. Leitung auf FAXCSI2, für die 3. Leitung auf FAXCSI3 usw. abzuändern.
Danach muss directfax mit ENDDIRFAX
beendet und wieder neu gestartet werden (RESTART *YES
).
Hintergrund dieses Problems sind Änderungen in der Firmware der Faxbox, die eine Verkürzung der Wartezeit beim "Abheben" beinhalten, so dass es bei Hauptanschlüssen vermehrt zum Fehler 'Kein Wählton' kommen kann, wenn der Parameter DTD nicht auf 'B' steht.
PC-Client – Kein Sendedialog (18030195)
Problem
Wenn man aber ein Dokument (Word oder auch Notepad) auf den DF-Drucker druckt, dann kommt kein Fenster mit dem Fax-Sendedialog hoch
- Infax, outfax, Gruppenverwaltung, Empfängerverwaltung laufen einwandfrei
- In CFGTCP, Auswahl 12 fehlte der Eintrag <host>.<domäne>. Den haben wir nachgetragen, dann den TCPSERVER re-startet (ADDLIBLE DIRECTFAXF, ENDSRV, STRSRV).
Lösung
Re-boot des PC löste das Problem
Details
24.10.2018-16:02 / RSC & P2 via TVW
- DFX-PC-Client 5.95 heute wieder neu installiert.
- Infax, outfax, Gruppenverwaltung, Empfängerverwaltung laufen einwandfrei
- Wenn man aber ein Dokument (Word oder auch Notepad) auf den DF-Drucker druckt, dann kommt kein Sendedialog hoch.
Auf der IBM i findet man im Joblog des TCPSERVER auch keine Einträge, dass die DFAXxxxx – Jobs gestartet würden. (auf der DEAET03 sind das in dem Moment 4 Stück)
Der Job FAXPC in SBS-DIRECTFAX läuft
In CFGTCP, Auswahl 12 fehlte der Eintrag <host>.<domäne>. Den haben wir nachgetragen, dann den TCPSERVER re-startet (ADDLIBLE DIRECTFAXF, ENDSRV, STRSRV).
Auch ENDDIRFAX/STRDIRFAX gemacht.
Keine Änderung.
Protokollierung auf dem PC eingeschaltet. Wir finden im Verzeichnis C:\Program Files (x86)\Toolmaker\Directfax\LOG einige Dateien
Darunter die instprintdriver – zuletzt geändert um 14:35
Start AddPrintProcessor .
Print processor directory:C:\WINDOWS\system32\spool\PRTPROCS\x64
LMUEJO4C
winprint
call add print processor.
AddPrintProcessor successfully added.
Printer Driver path:C:\WINDOWS\SYSTEM32\SPOOL\DRIVERS\X64\UNIDRV.DLL
Printer Help path:C:\WINDOWS\SYSTEM32\SPOOL\DRIVERS\X64\UNIDRV.HLP
Data file path:C:\WINDOWS\SYSTEM32\SPOOL\DRIVERS\X64\DFNTPRN.GPD
Config file path:C:\WINDOWS\SYSTEM32\SPOOL\DRIVERS\X64\UNIDRVUI.DLL
AddPrinterDriver successfully added.
Start AddPrintProcessor .
Print processor directory:C:\WINDOWS\system32\spool\PRTPROCS\x64
Error is:32DIRECTFAX
AddPrintProcessor found an older print processor.
AddPrintProcessor successfully added.
AddPrinter successfully added.
Neustart des PC vereinbart - danach lief es
Autor: RSC
Produkt – Version auf IBMi | 6.06 |
Produkt - Version Client | 5.95 |
Windows - Version | 10 |
Weitere(s) Produkt(e) | MS Office 2016, 32bit |
SMTP-Fehler 553 bei Faxmail-Versand (19000005)
Problem
Alle Faxmails bleiben im Status "Mail Aufbereitung" stehen.
In QSYSOPR gibt es für jedes Mail eine MSG-FAX1530:
Nachrichten-ID . . . . : FAX1530 Bewertung . . . . . . : 00
Nachrichtenart . . . . : Information
Sendedatum . . . . . . : 16.01.19 Sendezeit . . . . . . : 08:42:24
Nachricht . . . : SMTP-Fehler: SMTP Error: 553 5.7.1 <info@meinedomaene.com>:
Sender address rejected: not owned
Hinweis: Die Msg 553 geht vermutlich noch weiter, wurde aber bei uns abgeschnitten. Ich vermute, das sie lautet: „…not owned by user max.maus@meinedomaene.de"
– das sagt mir jedenfalls meine Google-Recherche.
Z.B. gibt es auf der URL https://community.alfresco.com/thread/207618-sender-address-rejected-not-owned-by-user
Diesen Hinweis:
Postfix log:
Mar 14 11:40:41 maildemo postfix/smtpd[22470]: NOQUEUE: reject: RCPT from alfresco.example.com[192.168.101.164]:
553 5.7.1
<venkat@example.com>:Sender address rejected: not owned by user alfresco@example.com;
from=<venkat@example.com>
to=<manoranjan@example.com>
proto=ESMTP helo=<alfresco.example.com>
CFGFAXMAIL sieht so aus:
Postmaster Email Adresse . . . . > 'ACME GmbH <info@meinedomaene.com>'
Email System . . . . . . . . . . > *DIRECTFAX
DirectMail/400 Mailbox . . . . . *OWNER
TCP/IP Port für SMTP . . . . . . *SMTP
SSL verwenden . . . . . . . . . *NO
SMTP AUTH Verfahren . . . . . . *AUTO
SMTP Benutzer . . . . . . . . . 'max.maus@meinedomaene.com'
Kennwort. . . . . . . . . . . . 'meinkennwort'
Es sieht so aus, als wäre der Benutzer, der sich beim SMTP-Server anmeldet (max.maus@meinedomaene.com) nicht der „Owner" des Benutzers ist, der als Absender genommen werden soll (info@meinedomaene.com).
Lösung
CFGFAXMAIL geändert in:
Postmaster Email Adresse . . . . > 'ACME GmbH <info@meinedomaene.com>'
SMTP Benutzer . . . . . . . . . 'info@meinedomaene.com'
Also login und "from" identisch gemacht. Damit läuft es.
Hilfreiche Website bei SMTP-Fehlern ist z.B. Auch:
https://support.google.com/a/answer/3726730?hl=de
Autor: RSC
Produkt – Version auf IBMi | 5.92 |
Telekom-Digbox: Nach Wechsel der Telefonnummer gehen keine Faxe mehr 'raus (19000205)
Problem
Die Konfiguration hatte lange problemlos funktioniert, bis aufgrund eines Fehlers der Verwaltung die Telefonnummer des ISDN-Anschlusses auf der Digitalisierungsbox erneuert werden musste. Danach:
- gingen keine Faxe mehr 'raus
- konnten Faxe einwandfrei unter der neuen Nummer empfangen werden
- beim Senden gab es für jedes Fax im Modem-Trace den CAPI Fehler (3481) Unallocated (unassigned) number
- (Siehe Tracedatei im IFS der IBM i: /Toolmaker/DirectFax400/debug/...ModTrc...txt)
Die Konfiguration sah so aus:
IBM i – LAN → TCUX-02 – S0-Kabel → Digibox der Telekom –→ Internet
Nichts davon war geändert worden, lediglich die Telefonnummer war neu.
Lösung
Auf der Digibox musste die neue MSN eingetragen werden. Danach lief der Faxversand wieder einwandfrei
Autor: RSC
Produkt – Version auf IBMi | 6.02 |
Empfangene Faxe werden nicht verteilt
Problem:
Seit heute gehen keine Eingangsfaxe mehr an die Lotus-Notes-Clients, eine Archivierung findet auch nicht mehr statt. Eingangsfax wird in WRKINCFAX als *NEW angzeigt.
Lösung:
WRKACTJOB SBS(QBATCH)
zeigt MSGW für einen Sicherungsjob und viele Fax-Jobs, die noch warten. Nach Abbruch des Sicherungsjobs läuft wieder alles einwandfrei.
Autor: MWE/05.11.2019 (Übernommen in CFL von RSC)
Kommunikation über internes Modem (2771 / 2793 / 576C): "Keine Leitungen verfügbar"
Dieser Fehler tritt nach einem Wechsel der Hardware (neue Maschine, anderes "Fax-Gateway") gelegentlich auf.
Problem
- Die Leitung ist korrekt konfiguriert (siehe Konfiguration Fax-Hardware - Internes AS/400 Modem (2771/2793/576C) die DFV-Einheit "CMNxx" ist Betriebsbereit.
- Die Telefonleitung (TAE-Dose) ist aktiv, man kann mit einem analogen Telefon an dieser Dose telefonieren
- Trotzdem geht die Leitung in den Status "FEHLGESCHLAGEN" und man findet in QSYSOPR die Fehlermeldung "Die Steuereinheit DIRECTFAX kann nicht angewählt werden. Keine Leitungen verfügbar."
Lösung
Den Befehl CHGNETA MDMCNTRYID(DE)
ausführen, dann directfax neustarten.
Autor: RSC
Produkt – Version auf IBMi | alle |
Der Steuercode ^ATTACH funktioniert nicht - es werden keine Dateien an das Fax angehängt
Ausgangslage (Fehlersituation): Das TIF-Dokument steht im IFS und die SPLF enthält den ^ATTACH Code. Beim Faxen wird die AGB Seite aber nicht mitgesendet.
Weitere Vorgehensweise: Nachfolgend werden die Prüfpunkte abgefragt, die erfüllt sein müssen, damit der Code ^ATTACH die zusätzliche Seite erfolgreich faxen kann. Am besten arbeiten Sie die einfach schrittweise ab, ohne Rücksicht auf bekannte oder vermeintlich sichere Informationen.
Prüfpunkte auf dem PC
- Eigenschaften der TIF-Datei prüfen. Mit IrfanView (Freeware) oder einem anderen Tool ist zu prüfen, ob folgende Bildeigenschaften (Image Properties) vorhanden sind:
File name: Endung muss TIF sein
Compression: None oder Huffmann Code
Resolution: 200 x 200 dpi
Original size: 1653 x 2338 (oder ähnlich für DIN A4)
Original colors: 2 (schwarz/weiß!)
Bei der Kompression gibt es noch andere Varianten, die auch funktionieren können. Abweichungen bei der Auflösung führen zu einer falschen Größe der Grafik auf der Faxseite oder zu rechenintensiven Skalierungsprozessen bei jedem Fax mit AGB-Seite.
Bei der Anzahl Farben darf nur 2 stehen. Wurde das Dokument mit Graustufen eingescannt, kann es nicht gefaxt werden: Es muss schwarz/weiß sein.
Die PC-Freeware IrfanView bietet eine Funktion, mit der man die Farbtiefe einer Grafik verringern kann.
Prüfpunkte auf der IBM i
- SIGNOFF machen und mit QSECOFR oder einem Profil mit entspr. Rechten neu anmelden, um alle nachfolgenden Schritte ausführen zu können.
- Lizenzprüfung mit CHKDIRFAX. Es sollte DF450=1 angezeigt werden, dann ist eine Hauptlizenz vorhanden ist. Bei 0 fehlt diese.
- Versionsprüfung mit DSPDIRFAXV. Es sollte mindestens 5.35f vorhanden sein. Wenn DirectFax unter IBM Release V5R4 laufen soll, ist 5.80h oder höher erforderlich.
- Mit CHGFAXVAL F4 auf Seite 2 den Parameter Faxmodem-Unterstütz. (MIXALL) prüfen. Er sollte auf *YES oder *EXT stehen (nicht ändern!). Falls er auf *NO steht, muss die ^FAX Steuerzeile ^MIXALL enthalten, damit der Attachbefehl funktioniert.
- Mit WRKSPLF nach der zu faxenden Spooldatei suchen und mit Auswahl 8 auf Seite 2 den Druckertyp prüfen. Dort muss *SCS stehen (^Codes in AFP oder PCL SPLFs werden nicht unterstützt).
- Spooldatei mit Auswahl 5 anzeigen und nach ^ATTACH suchen. Der Code muss am Dokumentende (letzte Zeile) oder in der ^FAX Steuerzeile (1. Zeile) stehen.
- Syntax des ^Codes prüfen. ^FAX Zeile:^ATTACH(PFAD/DATEI.TIF)Letzte Zeile:^ATTACH PFAD/DATEI.TIFFalls die TIF-Datei in einem QDLS Ordner steht (siehe WRKFLR), beginnt der Pfad ohne "/" mit dem Ordnernamen (z. B. DIRFAXHB).Falls die TIF-Datei in einem IFS Verzeichnis steht (siehe WRKLNK), beginnt der Pfad mit "/" und dem obersten Verzeichnisnamen (z. B. /Toolmaker).
- Mit WRKFLR für QDLS bzw. WRKLNK '/' für IFS prüfen, ob die TIF-Datei wirklich in dem im Attachbefehl angegebenen Pfad steht und der Dateiname richtig geschrieben ist. Wenn ja, die Datei und das Verzeichnis mit Auswahl 9 bezüglich Berechtigung R (Read) prüfen. *PUBLIC *RWX wäre OK. Wenn Benutzer DIRECTFAX angegeben sein sollte, muss er mindestens Leserechte haben.
Testfax
Nach Klärung der Prüfpunkte geht es im nächsten Schritt um ein Testfax. - Dazu mit WRKSPLFAX F4 die Musterspooldatei suchen und mit Auswahl 1 an das hauseigene Faxgerät faxen oder an die eigene Mailadresse senden (falls die DirectFax Mailfunktion voll funktionsfähig eingerichtet ist). Bitte unbedingt darauf achten, beim Parameter Steuercodes im Text ignorieren *NO anzugeben!
Falls die Spooldatei eine ^FAX Steuerzeile enthält oder es bereits eine Autofaxdefinition gibt, können Sie, statt WRKSPLFAX zu verwenden, die SPLF auch nach OUTQ DIRFAXPRT stellen und freigeben.
Prüfung von Fehlermeldungen
Falls das Testfax weiterhin die AGB Seite nicht überträgt, suchen Sie nach Fehlermeldungen an folgenden Stellen:
- DSPMSG QSYSOPR
- DSPMSG Benutzername (Eigentümer des Faxes)
- WRKACTJOB, Auswahl 5 vor Job FAXMIX, Auswahl 10 Joblog, Taste F10.
Keine Fehler zu finden: Enthält das Fax den ATTACH Befehl als Text, fehlt das Zeichen "" oder es gibt eine unerlaubte Leerstelle dahinter. Es kann auch sein, dass das Zeichen "" einen falschen Hexcode hat (richtig wäre x'5F'). Denkbar ist auch, dass einer der Prüfpunkte 4 und 5 bei der IBM i nicht beachtet wurde.
Falls Sie das Problem trotz Checkliste nicht lösen können, schicken Sie die TIF-Datei als Anhang an die Toolmaker Hotline (hotline@toolmaker.de) und beschreiben Sie kurz den Fehler.
Autor: RSC
Produkt – Version auf IBMi | alle |
Autofax schickt dem Absender die Nachricht FAXC00E: Keine Fax-Nr. für Spooldatei… (21000008)
Das System lief jahrlang problemlos. Seit einer Umfirmierung werden Faxe zwar "erkannt" und in die Warteschlange gestetllt, aber ohne Fax-Nummer. Im WRKFAXSTS ist die Faxnummer="???????".
Ursache
Durch die Umfimierung war der Firmenname so lang geworden, dass er die Seitennummer in der SPLF überlagert. Die Seitennummer ist aber die Bedingung für die Faxnummer. Deshalb konnte keine Faxnummer mehr ermittelt werden.
Lösung
Die Autofax-Definition mit Auswahl 2 überarbeiten und die SPLF neu laden. Dabei "Überlage
rungen anzeigen=J" auswählen.
Jetzt wird die Seitennummer wieder angezeigt und kann als Bedingung ausgewählt werden.
Autor: RSC
Produkt – Version auf IBMi | alle |
Faxmails über einen Office365-Server gehen nicht 'raus
2021-03-18
Wenn in CFGFAXMAIL SMTPSRV(..)
ein Server von Microsoft Office 365 eingetragen ist (z.B. "smtp.office365.com" oder "xxxxxxxxxx.mail.protection.outlook.com"), dann ist ein HOTPTF erforderlich.
Stand 2021-03: dieses HOTPTF steht für die Versionen 5.92 und 6.06 zur Verfügung. Ältere Versionen müssen aktualisiert werden.
Die Hotline wird Ihnen auf Anforderung das link zu diesem HOTPTF und die zugehörige Installationsanleitung schicken.
Schritt-für-Schritt-Anleitung
Erfahrungsbericht eines Kunden - mit Dank an Herrn Bettinaglio von AIM:
1. DirectFax mit dem Befehl ENDDIRFAX
beenden
2. CHGFAXPRF QSECOFR
F4, 5 x vorwärtblättern, bis zum Parameter EMAIL
dort die zu verwendende Absender-Adresse eintragen:
Bei der Kontrolle wurde bemerkt dass AS400 automatisch das Zeichen ' vor und nach der Adresse einfügt hatte. Die dürfen nicht sein!
3. CFGFAXMAIL
F4
Die von Microsoft festgelegte Absender E-Mail-Adresse eintragen:
Auch hier muss die Adresse ohne Hochkomma eingegebn werden.
4. STRDIRFAX
5. Konfiguration von Microsoft 365
Die letzte Aktion würde darin bestehen, Microsoft 365 so zu konfigurieren, dass es die direkte Kontaktaufnahme über Port 25 ohne Authentifizierung über die öffentlichen IPs des Kunden akzeptiert.
In diesem Fall wurde dies jedoch bereits in der Vergangenheit für andere Anforderungen getan, die über IBMi hinausgehen. Dies war also während unserer Tests schon so eingestellt.
Autor: RSC
Produkt – Version auf IBMi | 5.92 und 6.06 - für ältere Versionen nicht verfügbar |
Retarus-Leitung: startet kurz, geht dann wieder Status ENDE
Falls die Leitungsbeschreibung RETSUPP1
nach STRDIRFAX
kurz startet, dann aber wieder zum Ende geht, zunächst mit DSPMSG QSYSOPR
nach Fehlermeldungen von directfax suchen.
Falls der Verdacht besteht, dass die am Retarus Sendevorgang beteiligten Objekte unvollständig oder unbrauchbar sind, einmalig folgende Initialisierungsschritte durchführen:
Mit QSECOFR-Rechten angemeldet sein
ENDDIRFAX
DLTDTAARA DIRECTFAXF/DFRETFAX
CLRPFM DIRECTFAXF/DFRETFAX
ADDLIBLE DIRECTFAX
ADDLIBLE DIRECTFAXF
CALL CVTDFRETFA
STRDIRFAX
Retarus: die FTP-Verbindung kann aufgebaut werden, die Faxe werden aber nicht verschickt
2021-03-30
Problem:
Ein TELNET-Aufruf zum Server FAX4B.DE2.RETARUS.COM funktioniert mit den in WRKFAXLIN hinterlegten credentials.
Trotzdem zeigt das Joblog des Retarus-Job im Subsystem DIRECTFAX, dass der STOR-Befehl fehlschlägt:
Lösung:
Umschalten auf passives FTP. Siehe Retarus Support/Service - FTP umschalten auf Passivmodus